Date: Thu, 1 Apr 1999 12:42:10 -0600
From: "bigfoot" <p_thompsonnopsamoot.com>
Subject: turbo question (85 900 16v)


I need some direction on this. Last night, my 85 900 turbo did something I have not experienced before, and it has me worried. While driving, the oil light came on as I was decellerating. When I applied pressure to the gas, the light went back off. I pulled over immediately, and since I had just changed the oil hours before, I checked the drain plug (fine) and oil level, also fine. I proceeded into the grocery store, and when leaving, the light was back on and would not go off even when the accelerator was depressed. I pulled into the gas station to fill up, checked the oil level again, and looked for anything obvious - again nothing looked awry. The engine then started to make some clacking/clicking noise, almost like a "sticky lifter" sound. At this point I am getting really worried. I drove slowly home, hearing intermittent metallic "clacking" sounds, and there is no boost at all. Does this sound like a turbo that failed? I have never had one fail, so I am completely inexperienced with this. What other things should I look at? I am planning on taking it to my mechanic, but I would like some info beforehand so I can talk about it intelligently and know what to expect. Thanks for any quick responses!!

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2018 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]