Date: Wed, 07 Jul 1999 20:15:21 GMT
From: hgfdnopsamnl (Robin)
Subject: 9000 not running smootly...... Any help ?


Good morning / afternoon / evening fellow Saabers ! Today we encountered a very strange problem. A friend of mine bought a 1990 9000cd turbo griffin with a 2.3L engine (175.000 km) with a idle running problem. At first, the car was not running smooth when idling. It seemed that the car was running on 3 cylinders only. As soon as the rpm increased, the engine was running smoothly. We went to a Saab mechanic in Maasmechelen, Belgium (Johan, please comment…), and he was telling us it was either the direct ingition cartridge or the oxigen sensor. He 'mechaniced' around the cartridge and the problem seemed to be solved. As we were driving back to the Netherlands, the same symptoms reappeared, but not only when idling but also during the ride ( especially 60 - 90 kms/hr) . The Saab dealer in the southern Dutch area replaced the cartridge but nothing changed. The problem was still there. He found out that the engine got false air from the either the injectors, or the inlet manifold. He checked both, and changed the 'inlet manifold gasket'. The problem seemed to be solved, but reappeared when driving for a couple of kms. Has anybody experienced the same problem? Can anybody give me a clue where to look next? Tomorrow morning we're going to the dealer again to have the car fixed. Any help would be appreciated. As we only have 2.0L saabs at home, I have no idea where to look and locate the problem! Keep on saabing! Robin '87 9000i manual 320.000km '89 9000cdi Auto 220.000km '90 9000cdt griffin auto 175.000km (trying to become a real saab !!!!!!!!!!)

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]