Date: Sun, 23 Jul 2000 00:19:55 -0700
From: "JFS" <beenhad36nopsamail.com>
Subject: Re: SAAB 9000 CSE 2.3L Turbo 1997 - Check radiator indicator came up for 2 seconds


It happened to me, only after draining fluid and refilling. Mine had air in the system. "Mike Schuster" <mikeschuster2nopsam.com> wrote in message news:39791B3C.62EFF593nopsam.com... > Sounds to me like your coolant level is just a bit low. Probably, when you hit > the brakes, the coolant moved to the front of the tank and away from the > sensor. > I park my 93 9000CSE on a slanted driveway, and sometimes the check radiator > level indicator will come on for a bit, until the car is moved onto a level > surface. My guess is that the sensor is located towards the rear of the coolant > resevoir. > > Just add some water to the resevoir and you should be fine. > > Adel Abushaev wrote: > > > Good time of day, > > > > during the speed reduction from 55 mph to 0 mph (hardly) Check Radiator > > sign came up for 2 seconds then > > went out. Never happened after during the driving time, during the break's > > test or after startup (just went off > > normally in 1-2 seconds after startup). I think it's a contacts problem or > > so on. Can you suggest anything? > > > > Thanks in advance. > > > > Adel. > > -- > Remove nospam. from address to email me. > >

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]