Date: Thu, 07 Nov 2002 10:51:04 -0500
From: "D.S. Brown" <dsb3nopsam.edu>
Subject: Electrical diagnosis help


1994 900S V6, has run great for 126,000mi. Some recent electrical trouble, however. First sign of problems was the SRS light came on right after a morning start. Dealer DX indicated "code 1133 light shorted to ground." I was told there was nothing to do, so they reset it. It was fine for another 250 miles, then the same thing happened again right after morning start. Same SRS code comes up. Dealer calls Saab tech support who diagnoses it immediately (we thought), saying to replace the ingition switch. (They ask if we saw any other lights flash or erratic gauge behavior. I recall yes, but it had been so brief that I didn't concern myself with it, just the SRS light since this remained.) Dealer replaces ignition switch, resets SRS, and car does OK on their test drive. After I pick it up I get less than a mile away before I get erratic gauge behavior. The gauges go flat and the odo is dark. Gauges come back after a couple seconds, stay on for a little while, then go flat/dark again. This happens about 5-6 times during 5-8 mins or so. Most times it's really quick, but one time the gauges were flat/dark for 15-20 seconds. During the erratic behavior I notice that the Fuel and Info Display lights remain on for a couple seconds after the blips. The others gauges did not light. Finally, when things smoothed out after a few minutes, the SRS light came back on again. The dealer is going to check it out again and talk to Saab, but I would like to know if anyone has any tips. Could the ignition switch that they replace it with be bad? (It was a new part.) I have more info below that may be tangentially helpful. Thanks, Derek Brown 1994 900S V6 auto 126,000mi Notes: -Each time it was morning. Temp ranged from 45-60 degrees -Behavior occured with both the radio on and off -Behavior was much more erratic and worse afer ignition replaced, but it did smooth out after a few mins -The only electrical work I've done on it was to replace the radio about 850miles ago with a salvage unit. Also replaced SID bulbs. Things ran OK after this. Radio was dead after I did a head gasket overhaul about 1500miles ago. We don't know why it went dead after the head gasket. No good explanation except that the battery was disconnected during the job. Clarion had no good explanation. No other electrical trouble.

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]