Date: Thu, 16 Dec 2004 20:51:55 GMT
From: Juha <jiithemannospampii.fi>
Subject: Re: 99 9-5 Hi-Beam


Colin Stamp wrote: > On Thu, 16 Dec 2004 19:42:22 GMT, "TGS" <tgsnospamcess.net> wrote: > >>Hi-Beam on drivers side not working even though bulb is not burned out. >>Blue hi-beam indicator light on dash also not functioning... wires all >>look good... Anyone experience this problem? >> > > Yep. Not just me either. Mine was on a '99 9-3. > > There seems to be a common problem with the bulb monitoring system on > all Saabs around that era. > > What you're looking for looks like a relay, only orange. On the 9-3 > it's in the relay box under the bonnet, next to the bulkhead. When you > find it, try thumping it. I bet the light will come back on. > > The box is the sensor for the headlight bulb failure warning on the > SID, but it's design is sh1t. The only mechanical support for the PCB > inside comes from the solder joints to the base. Eventually one cracks > (almost completely invisibly) and a headlight stops working. To fix > it, re-solder all the joints along that edge. > > 'course, it could be something completely different... > > Cheers, > > Colin. monitoring "relay" (the orange one) is fairly easy to fix. You can find instructions about it from the net.

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]