Date: Sun, 01 May 2005 06:56:36 -0400
From: Malt_Hound <Malt_Houndnospamm*yahoo.com>
Subject: Re: erratic running


michael spencer via CarKB.com wrote: > i have a 93 saab 9000cse 2.0 16v the check engine light comes on it loses > power wont idle properly and has to be driven hard to make go.It has had a > new cat, lambda sensor been to the main dealer and still i have no joy ,the > car is normally lovely to drive could anybody give some advice,i dont want > to get rid but i am at the end of my tether please help Michael, What you are describing is the car going into what is known as "limp home" mode. Warning, do not drive your car more than absolutely necessary to get it somewhere safely. The cause of your check engine light can be determined by getting "flash codes" using that very same light. There are directions on this web site. http://www.townsendimports.com/ Sorry, I can't link to the exact procedure because this site is hosted on a server with a dynamic IP address. Let me know if you can't find it and I can email it to you in a pdf file. There are several common causes of the car going into "limp home" mode, probably the most common of which is old or incorrect spark plugs. When was the last time you changed them and what did you use? Even if it has not been that long, I would suggest you stick a new set in there. Be sure to buy only the original equipment NGK spark plugs as any others will quite likely cause this problem to recur very soon. If that does not fix it let me know as there are a few other common causes. -Fred W

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]