Date: 18 Jan 2006 10:28:58 -0800
From: "AndyD" <ard69nospamail.com>
Subject: Dashboard indicator malfunction


Sorry for the double post. My newsreader didn't display the first one... A week or so ago, the audible tick on my (UK spec) 1999 9-3 indicators stopped working. The indicators themselves were working and the dashboard flashers were too. Today, the dasboard flashers stopped working too, although occasionaly came on from time to time. At the same time I noticed the SID was not displaying mileage information, just some dashes ( ----). The radio channel, temperature & clock were all fine. The indicators outside the car were operational, however. Does anyone have any idea where to start to investigate this? I'm sure if I take it in to the dealer it will be expensive, so I'd like to try to isolate the problem myself, especially as it is annoying rather than critical. I have searched some of the postings here and saw there are quite a few peculiar SID issues, but don't understand why this would affect the dashboard indicator ticking or flashing. Up to now the SID has been faultless as have all the other electrics. I've owned the car since 2001. 100K miles. Air con (not climate) and no cruise control. Thanks for any assistance. AndyD

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2018 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]