Date: Wed, 6 Sep 2000 00:53:00 -0400
From: "George Strait" <gstraitnopsamhfire.net>
Subject: Re: 900 After-running


<saabsternopsameja.com> wrote in message news:8p3djd$3ce$1nopsam1.deja.com... > I have an 85 900 8v with Bosch Mechanical Fuel Injection. The engine > runs great, but when I shut off the ignition sometimes the engine runs > on. It sounds really ugly. Checked the ignition timing and it was > correct. Brought it to a tech who said that the cause was most likely > carbon deposits in the combustion chambers, advised me to use Fuel > Injector Cleaner with every fill up for the next month. He squirted > cleaner on my throttle plate and the airflow sensor plate (and > afterward the engine idled at 1100rpm, rather than the 875 at which it > idled when I brought it in. The tech said it would return to normal > with time; it almost has.) > > Nearly a month has passed and the engine still runs on. I've been > through 3 bottles of Fuel Injector Cleaner already. Short of removing > the head and cleaning the combustion chambers and valves manually, I'm > not sure what I can do. Perhaps the cause is something else. The > auxillary air valve? Might explain my slightly high idle. If anyone has > any ideas about how to nix this afterrunning, I would much appreciate > them. Try a higher octane fuel.

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]