Date: Thu, 16 Jul 1998 14:25:44 -0500
From: wild.childnopsamoot.com (Dennis Park)
Subject: 9000S Rough Idle


After roaming through this newsgroup and SAAB.net for a while, I think that it may be a problem with my O2 sensor. I've checked as many vacuum tubes as I can and they seem fine. Here's the problem: Upon starting the car, the engine will rev up to about 1,200RPM. A few seconds later it will go down to about 200 or 100. Sometimes it will stall. The only way I can remedy this is to step on the gas and keep a constant RPM around 1,000 for a minute. After this,the engine stablilzes and will not run rough for the rest of the day. The engine shakes rather violently. I fear that I may damage it unless I remedy the problem sooner. Why is it that it only happens when the car has been sitting for a long time (i.e. 5 hrs or overnight)? There is no decrease in power while driving. Actually, it runs great with the exception of the rough starting. I think it's the O2 sensor. What does it exactly do? Where is it? (I think I know where, but I"m not sure.) I don't want to replace a part that doesn't need replacing and won't fix my problem. Any help would be great. Thanks in advance. Dennis Park

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]