Date: Mon, 08 Mar 1999 16:47:22 -0800
From: Justin VanAbrahams <jvanabranopsam.com>
Subject: Re: Power Steering noise in '93 Saab 900SE


Matthew Crump wrote: > > Hello, > > I have recently purchased a manual '93 SAAB 900SE with 112,000 miles on the > clock and a good service history. > Has anyone else come across a similar problem and, if do, what was the > solution ?. Although it's hard to diagnose a sound remotely, I can say a recent similar experience with an '89 9000CD led us to a kinked power steering hose that was obstructing proper fluid flow. The noise would start up shortly after starting and would not go away... it was quite annoying... we replaced the pump and the belt, and it wasn't until my mechanic put it up on a rack that we could see the hose... Along those same lines, I would check the filter in the power steering system - it's easily accessible. If it becomes blocked for whatever reason you'll get The Noise. I can't really think of a cause for it to be blocked, but since it's easy it's worth checking. The chances of it being a failed pump is pretty low, as they usually last longer than 112k (my '85 has 190k on the original, for example). Good luck, -Justin

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]