Click Banner for Details on this Saabnet.com Classified

Date: Thu, 24 Jun 1999 11:42:21 -0700
From: "John Weiss" <jrweissnopsamet*NOSPAM*.com>
Subject: Re: electrical system fun...


Sounds like a bad ground. You can usually trace it to corrosion in one of the tail light or turn signal clusters (I'd try the rear ones first, since the backup lights seem to be involved). I also had a battery ground cable corrode almost completely through... -- John R. Weiss Seattle, WA Remove *NOSPAM* from address for e-mail reply Pete <petelnopsampernet.com> wrote in message news:57qc3.177$VL6.31295nopsam2.voicenet.com... > I have a new problem with my 84 900T. > On Monday the left turn signal starting clicking the relay inside at > twice the normal speed, and not flashing the outside lamps. No big deal, I > figured it was a burned out light bulb causing some weird behaviour. > Last night I put the car into reverse to shut things down, and I notice > that the oil light, the battery light, come on and the tach shut off > dropped to the resting position ). I take it out of reverse - lights go > off, tach pops up, into reverse - lights come on, tach shuts off. > I think I had this problem with my 78 99, but I don't remember every > finding out what the problem was, just that I moved some wires around and > things worked normally later. Has anyone else already seen or solved this

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]