Date: Sun, 29 Aug 1999 09:23:40 +0300
From: Roy =?iso-8859-1?Q?Bj=F6rkstrand?= <nospamroilonopsamut.fi>
Subject: High idle on 900i 16v


My 900 -91 has a high idle. The idle stays between 1100 and 1300 - very ocassionally it drops down to normal but then the idle is a little bit rough. For some time ago the idle was stucked even higher, but it happened only now and then (when changing from 1st to 2nd idle dropped under 2000 after a few seoconds). But now idle stays constantiously the same - 1100-1300. I cleaned the idle control valve and the throtle plate, but it didnīt help. When cleaning the throtle plate, I noticed that there were some "moisture" at the bottom of the "throttlepipe", the larger pipe where the pipes to the sylinders get attatched. Is this normal? It seems to me that there are two possibilities: 1. The engine gets too much gas. -The cold start injector could be leaking. What might be the accurate symthomps in this case? -Engine control unit (the small one in the engine compartment on the left) has gone bad (if it controls injection too). -Thermo sensor that gives the signal to the cold start injector has gone bad. Where is it located - is it the same one that gives signal to the temp gauge. 2. It gets too much air. -Airleak - no sign of it. -Idle control valve - cleaned and moves freely. Might still be the case. -Electronics gives faulty signal to the idle control valve. And then it can be that the idle is bad (new plugs though) and the electornics keeps the idle high in oder to keep the engine running. Anyway I would appreciate any suggestions and comments, Thanks Roy Ps. Do you have any hints in changing the front shocks?

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]