Date: Tue, 5 Feb 2002 20:48:35 -0000
From: "Grunff" <grunffnopsam.com>
Subject: Re: Oil Pressure Light


"Jason Dodds" <jasondoddsnopsamhlink.net> wrote in message news:aHW78.12022$3E5.994504nopsamread2.prod.itd.earthlink.net... > I've got a 95 900S with 120K miles on it and I am having a problem with the > oil pressure indicator. I can start my car and drive it for a while (10 > minutes) and whenever the RPM's drop (at stop light or slowing down), the > oil pressure indicator light comes on and I get an alert on my console (red > triangle with exclamation point in it). This is starting to happen more > frequently, and I don't know if it is a faulty sensor going out or there is > something seriously wrong with my engine. Has anyone ever had this problem > before. If anyone has any tips or fixes, I'd love to hear them. > Stop!! Don't drive your car anymore until you see to this - seriously. If you do, you're risking major engine damage. It may well be the sensor - if it is, then great, it's a cheap part, and easily replaced by the home mechanic. However, if you really do have low pressure, you can cause serious damage. Two options for testing the sensor - a)borrow/hire/buy an oil pressure guage and appropriate adaptor. Install it, run the engine, and check the pressure. Is it within spec? b)borrow/buy a new or known good used pressure sensor. Wire it in, and see if you get the same problem. If the sensor is fine, then you need to start looking at reasons for low oil pressure. There are many causes. Let us know once you've tested the sensor. Grunff

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]