Date: Sun, 15 Jun 2003 02:39:03 GMT
From: Leighton Hasselrodt <reclinernopsamine.rr.com>
Subject: '83 900: No Power to Radio


After three years of having my 1983 900s which came to me without a radio, I finally bought a new Sony CD player/radio.(how I survived without is a whole other story) There was a jumble of wires under the dash that I sorted out and could logically tell which ones were speaker and power. I made the educated guess that the only black wire was ground, this I tested with a continuity tester. The only Red wire I figure is the Hot power lead (switched) . There was no yellow wire which I am guessing would be the un-switched power. In any event there is no current flowing through the red lead. I've tested with one of those volt/amp light probes and I've tried connecting the radio... nothing. I checked fuses, dome light works, still no power with the car on or off.I did notice I was missing a fuse for the seat heater and cornering lights, but I can't see those being connected. I'm wondering if there is some fuse or connection under the dash. My fan selector switch only works on full so I know that something is messes up in there. Also, if this has anything to do with it...I have a power antenna which was broken, physically, when I got the car. In any even the new radio unit I got does have a banana type plug that fits perfectly. Hoping that you been-there-done-that problem solvers can help me out. thanks Leighton

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]