Date: Tue, 22 Jul 2003 03:17:48 GMT
From: 'nuther Bob  <notBobsaddressnopsamsclosed.com>
Subject: Re: '97 900 SE - coolant leak


On Mon, 21 Jul 2003 23:39:22 GMT, "Zuke" <zboldnopsamet.com> wrote: >It's probably coming from the water pump. I've got the same problem. No >doubt other people, too. This is another Saab specific, like the missing >pixels on the display, the crappy power antenna, and I am sure there are >more Saab specific problems whic are never fixed from year to year. It's not a known issue on the NG900. There was a problem with the water pump shaft on the '94's and 95's. This problem was not only "fixed" with a modified design in 1996, but Saab conducted a "customer satisfaction" campaign to replace them all. One thing to check, after you check all hoses, thermostat cover, etc, is the head gasket. There is an issue with some engines built before late 1997 with head gaskets. In late '97 they changed the torque specs for the gasket to deal with the problem. The also discovered a problem with the strut bearings, which was fixed with a redesign/updated part, as was the issue with the tonneau motor (fix for existing, modified part for future), and a few others. So, in contrast to your suggestion, Saab does indeed fix problems from year to year and often makes the corrections at no cost to the consumer - in contrast to many other manufacturers. Bob

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]