Date: Sun, 20 Jul 2003 15:18:22 +0100
From: "Hardgrafter" <richard.m.lewisnopsamo.net>
Subject: Re: electrical fault on my 900


Thanks I managed to get hold of some contact spray, not sure if that make but it alows better connection on the battery terminal. The battery looks old but still got some life in it if i need to change the battery do you have any brands or makes that i should look for. i had a varter battery in my last car and that worked well! "'nuther Bob" <nooneherenopsamaddress.com> wrote in message news:19ughvga219kgj20bfucbdsbrceemanafenopsamcom... > On Fri, 18 Jul 2003 19:17:05 +0100, "Hardgrafter" > <richard.m.lewisnopsamo.net> wrote: > > >I have got a 1995 saab 900 turbo > >Went to start it today and everything seemed to be going ok, the little > >screen said checking etc > >i waited till it said ok, then turned the key to start the car and the whole > >cars electrics went down the dash board went completly off no lights were > >lit up anywhere, it even reset the radio.its as if there is a loose > >connection or somthing. > >Does anyone have any ideas of what could have caused this?? > > > >i then left it for a bit and it started ok, just a bit paranoid now of it > >happening again > > > I'd start by checking the battery connections to make sure they are > clean and tight. Also, take a voltage reading on the battery and > see what it says. > > Bob

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]