Date: Mon, 01 Sep 2003 19:26:52 +0100
From: Grunff <grunffnopsam.com>
Subject: Re: Saab 900 Turbo 8 - what's broken?


Mike P wrote: > I've got a 1988 T-8, 202K miles. It's running OK, but I only seem to be > getting low boost level - maybe about 1/3 into the orange. It's also been > hesitating on pickup. The last couple of days it's also been hard to start > when cold. Warm up reg has been replaced recently. > > Spoke to BPV in Slough, they suggested the misfire could be the plug leads > because non-saab ones can interfere with the APC - possible or no? Also > suggested I try disconnecting the pipe from the APC controller to the > Wastegate actuator. I did this, now I get boost right up to the red as I > think I should, and the misfire has vanished, apart from when the car is > cold. > > So, is my APC solenoid knackered. Again? What else could it be? I haven't > replaced the vacuum hose yet, but ordered some today. Could be your APC solenoid is faulty, or it could be that the APC is detecting knock and legitimately cutting back the boost. Easiest way to check is to borrow a spare APC solenoid and install it. If it fixes the problem, the bingo. If not, you have another problem. The other problem falls into two categories: [a] you really are getting knock, which is being correctly detected, or [b] you aren't getting knock, which means either the knock sensor is faulty, or the leads are interfering with the APC. If [b], then it's easy. If [a], then you have some fault finding to do. Replace plugs, leads, check timing, etc. etc. -- Grunff

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]