Date: Tue, 27 Jan 2004 09:02:21 -0700
From: "Zon" <johnnopsamy-to-group.please>
Subject: Power antenna fixed!


Hi, I have had problems with my power antenna since I bought my '99 Saab 9-3 just before Christmas, and couple of weeks ago I asked for help in this newsgroup. I got bunch of good advices from many of you, which greatly helped me to diagnose the system. The problem I had, was totally dead power antenna. First, it was stuck of dirt, and I did clean and oil it. That did not help. I ruled out mechanical problems, and found that antenna motor did not attempt to do anything. Saab dealer's solution would have been whole antenna assembly costing some 250-300USD. I took whole assembly and even electrical motor in it in pieces and after all, the only thing broken was a thermal cut-off fuse inside the electrical motor, which costed me 45 cents. I believe dirt in antenna had got antenna stuck, and thermal cut-off fuse had to break the current always when radio was switched on and everytime it was shut off. Of course, this was not a matter of concern for previous owner and finally this poor little thermal cut-off fuse got tired of trying, and decide to give up. So, If you have dead power antenna motor, check the fuse inside it! BR:Z

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]