Date: Fri, 18 Jun 2004 22:43:43 +0100
From: "ice_cream" <PostTonospamOut.com>
Subject: Re: High Beams Stuck On


Brian, Had similar problems with 94 9000, although lights went off when switched off, they could get stuck on high beam, or not go onto main beam at all. Thought at first it was column stalk, but thumping relay box under bonnet would temporarily correct. Fixed by changing relay. <dustoff361nospamo.com> wrote in message news:562634e4.0406161734.54925038nospaming.google.com... > Hello, > > So, I was driving ('95 900SE) at night recently, using the high beams > intermittently, when all of a sudden I realized the high beams decided > to stay on all the time. The blue panel light was not lit, although > the high beams were always on. Then, when I turned my car off the high > beams remained on, even with key out of the ignition, so I had to pull > the high beam fuses to turn them off. Seems like the high beam switch > next the steering wheel is broken into the "on" position. Anyone know > where I can find some instructions on how to replace it? Or get to the > switch and clean the contacts maybe. Then again, maybe I'm missing > something simple here, an easier fix than I think. > > Any help is greatly appreciated. > > Brian

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]