Date: Fri, 23 Jul 2004 19:12:37 -0400
From: "Jim M" <jbmoore3nospamnospamast.net>
Subject: Re: engine mounts on 97 900 s


I have a 1995 900S, and I just replaced all the mounts a few months ago at 105,000 miles. I paid $263 at Eeuroparts.com for all three. It was the "front" mount that was actually broken; replacing them all at once seemed logical to me at the time. It was a fairly significant little project to do in the garage on axle stands, however, for a real Saab tech on a lift it should be pretty easy. Are you sure yours are actually gone? Did this condition occur suddenly? With new mounts, the gearshift still moves quite a bit, mostly in the front to rear direction, when you push the GO pedal. My front motor mount snapped suddenly one night when I kinda side-stepped the clutch at a green light. It was VERY evident that something broke. The oil pan actually was resting on the sub-frame, resulting in lots of noise and vibration. Hope this helps, Jim "Trastic" <trasticnospamail.com> wrote in message news:40ff9a76$0$280$cc9e4d1fnospam.dial.pipex.com... > ello > how much does it cost to have them replaced? my gearstick is wobbly when i > push the accelerater and i've been told it's usually engine mounts that are > the problem. > > > cheers > >

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2019 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]