Date: Thu, 09 Dec 2004 05:43:35 GMT
From: Wemic <djackso2nospamnospamp.rr.com>
Subject: Re: No Horn


OKOK! wrote: > "Wemic" <djackso2nospamnospamp.rr.com> wrote in message > news:DaMtd.39370$1u.10017nospamter.nyroc.rr.com... > >>Hi all, >> >>I have a 1989 Saab 900 with a horn problem. My problem is simply this: >>one day the horn worked, the next day it didn't. I checked the fuse, >>replaced the horns and the horn relay to no avail. Needless to say, my >>car will not pass inspection with a non-working horn. Anyone hear of >>this problem before or can think of something I haven't to fix it? >> >>Thanks. >> >>Wemic > > > Hi Wemic, > Get a light-bulb and a bit of wire to test the circuit, or better yet: a > "spanningzoeker" (Or whatever that is called in English... :-D ) You'll find > the cause in no time. > > There are actually 2 horns (one next to the air filter, and one under the > bumper (outside). > The chance of both failing at the same time is about zero...... > > Anyway, you're almost there: > Only 2 possiblilities left IMHO: wiring, or switch on steering wheel ... > > Good luck, > Richard. > > Hi Richard, Should have mentioned, only one horn was hooked up when it was working. For some reason, the prior owner had removed the one by the filter. Not being an electrical genius, at what point do I test the circuit? Also, I pried up the two pads on the steering wheel to take a look and they looked OK...it seems unlikely they both would fail on me. Are these pads what you refer to as the switch or is there something more ominous that I need to look at? Thanks, Derek

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]