Site News - 1/3 Saabnet.com Member of the Year: DougM
Date: Tue, 12 Dec 2006 22:47:56 +1300
From: Richard Sutherland-Smith <richard.ssnospamr.net.nz>
Subject: Re: Saab 9-3 TID 5door hatch 2.2 SE


In message <1165870889.482158.94690nospam000cws.googlegroups.com> Stephennospamwn84.orangehome.co.uk wrote: > Please help > I have a saab 93 2.2 tid and I get the engine managment light on from > tim to time it is hard to start from cold in the morning but it will > start in the end I seem to have a loss of power however I can get to > about 60 mph to 90 mph in time and once running the car is happy to run > along at this speed I think it may be ether the fuel pump not sure > which one? one in the tank or one at the engine? or the turbo? I do not > hear a "whur" as the turbo cuts in I think it should cut in after 2000 > rpm should it not? or the only other thing it could be is the engine > managment system its self ie the brain?? please help as im at my whits > end and I think this car is about to cost me a fourtune please help > > thank you > Injector seals are a problem on this engine. It can run but not well. -- Richard Sutherland-Smith 19 Webb Road, Wanganui 4500 New Zealand

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2022 - The Saab Network - saabnet.com.
For usage guidelines, see the Mission & Privacy Notice.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]