Site News - 11/22 Member of the Year Voting
Date: 27 Apr 2007 04:51:08 -0700
From: p digital <phillipdyenospaml.com>
Subject: Re: a few things to discuss....95 900se turbo 2.0


On Apr 25, 3:54 pm, still me <wheeled...nospamo.com> wrote: > On 25 Apr 2007 04:22:08 -0700, p digital <phillip...nospaml.com> wrote: > > >I keep replacing my head lamp bulb and and as soon as i flip on my > >high beams i get the front light bulb failure message on my SID...any > >suggestions on that?? > > Is the lamp burning out? Perhaps you are touching the bulb with > fingers when installing? Is the connector on tight? If not, time to > start checking the HB circuit - you may have a direct short of some > sort that is drawing large amounts of power through the bulb. > > >Secondly, my ABS light came on and now is staying on constantly...i > >haven't had a chance to remove my wheels to see if the sensor light > >has been jarred as of yet... > > Step by step on that one... check the brakes, check the sensors, etc. > > >thirdly, i am about to replace my control arms and bearings which my a > >horrible dry squeaking noise when i turn left to right. i have > >101,000 miles on the car and am asking the question as to ...should i > >change m rear shocks as well...i think the cars has struts correct?? > >if so, any recommendations on the types of shocks and control arm i > >should look for?? > > The rear shocks are just "shocks". The noise is likely your front > strut mounts and/or bearings. Replace them. Do the struts if you are > in there. Your control arms could be bad but it's less likely. The > ball joint does sometimes wear and replacing the arm is the only way > to repair. But, it's less common of a problem at 101K. > > If you can afford it, buy 4 adjustable Koni's. You won't regret it. > > >lastly i am going to replace my plugs and wires....cars seems to want > >to stall when i am coming to a stop sign...but fires right up...i am > >sure it needs a tune up..so i'll start with the wires and plugs....a > >little slow on power i am noticing....i am not getting the punch in > >third gear when i am reeling in all the "ricers" on 95 north!!!! any > >suggestions on the brand of plugs and wires! > > You don't have wires, you have a direct ignition cassette. Replace > your plugs every 10K with the STOCK plugs. Change the air filter. Run > a bottle of Techron Fuel System Cleaner (accept no substitutes!) > through. Clean the IAC. > > You need to know about this site:http://pages.infinit.net/mlbriand/index.shtml thanx for the quick help! i am going to get my baby up to specs again! oh, weird thing happened yesterday. my odometer/speedometer stopped working...i am going to check the cable which is underneath the tranny i think....bu t once i get it working again...is there anything i have to do to re-synch it with the SID? cause of course i am not getting my distance to empty and other things...due to the malfunctioning? thanks again.

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2021 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]