Date: 16 Nov 2006 06:07:38 -0800
From: "Rick" <rpmccreedynospamzon.net>
Subject: 89 900 wiper motor not putting out + engine surges at low speeds


Just picked up a 1989 900 turbo convertible with electrical issues. I have 2 main problems-wiper motor runs but not strong enough to make it across the windshield + at idle the engine surges. I know there are some electrical bugs in the car because when I turn on the wipers the side marker lights come on. When I step on the brake 3 bulbs illuminate on the left/1 on the right & something lights up in the front as well, although I haven't checked to see which bulb that is yet. When I got the car the taillight bulbs were screwed up-wrong bulbs installed & some were corroded. I replaced a few but need to pick up more. For the surging issue I heard it could be a fuel delivery problem so I tried fuel injector cleaner & replaced the fuel filter but it didn't help. I'm wondering if a lot of these problems could be related because the car didn't surge when I test-drove it nor was there a problem with the wiper motor. That is until I took it on the highway (1st time in a couple of months according to the previous owner). Any advice would be much appreciated.

Return to Main Index

The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]