04' Aero Wagon Brake Lights Stuck On - Saab 9-5 Bulletin Board - Saabnet.com


[General | Members | C900 | 9000 | NG900 & OG93 | 93 | 95 | NG95 | 99 | Sonett | Vintage Models | Performance | Detail | Clubs & SOC | Other Cars | FAQs | Gifts | Member Photo Galleries | Member Directory | Classifieds | Service/Mechs | Manuals | *Buddy Registry | *Mileage Registry | Polls | What's New | Raffle | Photo of the Month | Sponsors]

95 Bulletin Board
1999-2009 [Subscribe to Daily Digest]
(Search Author's Posts: e.g. Keyword:username)*Members Only


[Main 95 Bulletin Board | Post Followup | BBFAQ ] [ Prev by Date ] [ Next by Date ] Member Login / Signup [Latest Member Gallery Photos]
04' Aero Wagon Brake Lights Stuck On
Like This Post:
Posted by Thewagono [Email] (more from Thewagono) on Sun, 12 Jan 2020 17:36:18 Share Post by Email
Alert me when someone posts in this thread:

Did several searches on this here, but I didn't seem to find someone with the same exact symptoms.

Earlier this week, got "Brake Light Failure" SID message, GF told me she thought my driver's side was out. Finally got a bulb this weekend, swapped out (bulb did look a little toasted), but still showing "Brake Light Failure". Got GF to operate brake pedal for me to look first hand, turns out all three brake lights are stuck on with running lights, just shine a little brighter when brake pedal is depressed.

Pulled fuse for brake lights, lights go out and stay out when operating brake pedal (expected). Pulled fuse for right side running lights, only running lights go out (brake lights still stuck on). Pulled fuse for left side running lights, running lights go off but so do brake lights - now operating correctly with brake pedal. Note: I also have the optional front running lights accessory (previous owner installed) - with that left running light fuse removed, left front running light is off but turns on with the operation of the brake pedal. SID message also switches to "Rear Light Failure" with this condition.

I inspected wiring harness going into left side tail light assembly, some wear on the tape/heat shrink but inner wires and insulation appear to be intact and in good condition. No obvious corrosion in the bulb sockets. Searches indicate corrosion more common with sedan vs wagon due to location of wiring harness.

Stuck on next move - is brake light switch to blame? Should I do a more thorough inspection of connections/bulb sockets to try to find some corrosion?

posted by 66.31.13...
Posts in this Thread:
Alert me when someone posts in this thread:

Post a Followup

No Site Registration is Required to Post - Site Membership is optional (Member Features List), but helps to keep the site online
for all Saabers. If the site helps you, please consider helping the site by becoming a member.

Name: Member Login / Signup [Latest Member Gallery Photos]
E-Mail: (Optional)
Re-Enter E-Mail: (Confidential & Secure - Not revealed to other users!)
Note: Please check your spam folder for BB responses.

Subject:

Posting rules are simple - No for sale/wanted ads may be posted here - use the site classifieds.
You may not cross-post your message to multiple BBs.
Not permitted: political/religious topics and being disrespectful (personal attacks, insults, etc...).
Site Members do not see any red text, inline ad links, bottom of page anchor ads, box ads, or anti-spam check.

Message: (please no for sale/wanted classifieds - post those in the Saabnet.com Classifieds)
Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).


Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post above, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).

Optional Link: (e.g. http://www.saabnet.com/)
Link Title: (Optional)
Optional Photo/Image Link: (e.g. http://www.saabnet.com/img.jpg)
Photo/Image to Upload: [Member Only Feature] - Sign Up





The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]

This is a moderated bulletin board - Posting is a privilege, not a right. Unsolicited commercial postings are not allowed (no spam). Please, no For Sale or Wanted postings, SERIOUSLY. Classifieds are to be listed in The Saab Network Classifieds pages. This is a problem solving forum for over 250,000 Saab owners, so expect to see problems discussed here even though our cars are generally very reliable. This is not an anything goes type of forum. Saabnet.com has been a moderated forum since 1988. For usage guidelines, see the Saabnet.com Mission and Purpose Page. Please remember that you are not anonymous. Site Contact | Site Donations | Other Sites by SP - Poverty2Prosperity.org
Your address is: 18.204.227.117 - Using CCBot/2.0 (https://commoncrawl.org/faq/) - Logged.


Site Members do not see red text instructions, bottom of the page anchor ads, or box ads.
Click here to see all the Site Membership Benefits!