Re: Stumbling/Stall on cold start - Saab 9-5 Bulletin Board - Saabnet.com


[General | Members | C900 | 9000 | NG900 & OG93 | 93 | 95 | NG95 | 99 | Sonett | Vintage Models | Performance | Detail | Clubs & SOC | Other Cars | FAQs | Gifts | Member Photo Galleries | Member Directory | Classifieds | Service/Mechs | Manuals | *Buddy Registry | *Mileage Registry | Polls | What's New | Raffle | Photo of the Month | Sponsors]

95 Bulletin Board
1999-2009 [Subscribe to Daily Digest]
(Search Author's Posts: e.g. Keyword:username)*Members Only


[Main 95 Bulletin Board | Post Followup | BBFAQ ] [ Prev by Date ] [ Next by Date ] Member Login / Signup [Latest Member Gallery Photos]
Re: Stumbling/Stall on cold start
Like This Post:
Posted by andtheHawks [Email] (#2527) [Profile/Gallery] (more from andtheHawks) on Sat, 19 Sep 2020 17:03:07 Share Post by Email
In Reply to: Stumbling/Stall on cold start, Mike Johnson, Fri, 18 Sep 2020 06:14:40
Alert me when someone posts in this thread:

I too have a 2004 2.3t (linear) I have been having same symptoms now for about 3 months... after about 3 months of progressively hard starts (so all in all probably 6 months). This is just an issue for the first start of the day (sitting 8-12 hours)
-usually starts, then immediately stalls gently. Second start is perfect and rest of day fine. Drives fine, no codes.

It has gotten worse last week of cold temps- now it may stall twice and less gently, then starts just fine on third attempt.

- I tried the prime-the-pump-five-times to check if its the check valve in the fuel pump that may be letting gas bleed from engine.... This doesnt do anything for me.

-I then measured pressure at the rail and pressure all seems normal and holding fine (around 40 psi)

-I then cleaned the MAF

-I then swapped in new injectors, DIC and plugs as a hail mary sort of fix, and why not the DIC and plugs were in range for replacement, (the injectors were a sort of tinkering what-the-hell scratch to itch)...

nothing changed.

Fuel trim readings short and long term all seem normal....

maybe its one of these things that a new battery will fix... though I now feel more like its got to be the fuel check valve, which i am just avoiding doing.

I have been moving very slow to deal with this for a variety of reasons.

Next things to look into more closely?: Check valve, MAF, air intake temp sensor (MAP)???? Maybe might just let my mechanic have it for a week....

I think my wife is buying a 2010 9-3 sportcombi which may make that easier to do...

so it goes...

hope there is some clarity regards this for you soon. and me too! :)




->Posting last edited on Sat, 19 Sep 2020 17:14:33.
Posts in this Thread:
Alert me when someone posts in this thread:

Post a Followup

No Site Registration is Required to Post - Site Membership is optional (Member Features List), but helps to keep the site online
for all Saabers. If the site helps you, please consider helping the site by becoming a member.

Name: Member Login / Signup [Latest Member Gallery Photos]
E-Mail: (Optional)
Re-Enter E-Mail: (Confidential & Secure - Not revealed to other users!)
Note: Please check your spam folder for BB responses.

Subject:

Posting rules are simple - No for sale/wanted ads may be posted here - use the site classifieds.
You may not cross-post your message to multiple BBs.
Not permitted: political/religious topics and being disrespectful (personal attacks, insults, etc...).
Site Members do not see any red text, inline ad links, bottom of page anchor ads, box ads, or anti-spam check.

Message: (please no for sale/wanted classifieds - post those in the Saabnet.com Classifieds)
Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).


Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post above, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).

Optional Link: (e.g. http://www.saabnet.com/)
Link Title: (Optional)
Optional Photo/Image Link: (e.g. http://www.saabnet.com/img.jpg)
Photo/Image to Upload: [Member Only Feature] - Sign Up





The content on this site may not be republished without permission. Copyright © 1988-2021 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]

This is a moderated bulletin board - Posting is a privilege, not a right. Unsolicited commercial postings are not allowed (no spam). Please, no For Sale or Wanted postings, SERIOUSLY. Classifieds are to be listed in The Saab Network Classifieds pages. This is a problem solving forum for over 250,000 Saab owners, so expect to see problems discussed here even though our cars are generally very reliable. This is not an anything goes type of forum. Saabnet.com has been a moderated forum since 1988. For usage guidelines, see the Saabnet.com Mission and Purpose Page. Please remember that you are not anonymous. Site Contact | Site Donations | Other Sites by SP - Poverty2Prosperity.org
Your address is: 34.239.179.228 - Using CCBot/2.0 (https://commoncrawl.org/faq/) - Logged.


Site Members do not see red text instructions, bottom of the page anchor ads, or box ads.
Click here to see all the Site Membership Benefits!