Re: Radio - No Sound - Saab 9-5 Bulletin Board - Saabnet.com
Site News - 7/20 New Member Feature: Fewer Ads in Classifieds & More | 7/20: Saab Convention Photos | 7/11: Saab Photo of the Year Winners | New Feature: BB Daily Digest Email

[General | Members | C900 | 9000 | NG900 & OG93 | 93 | 95 | NG95 | 99 | Sonett | Vintage Models | Performance | Detail | Clubs & SOC | Other Cars | FAQs | Gifts | Member Photo Galleries | Member Directory | Classifieds | Service/Mechs | Manuals | *Buddy Registry | *Mileage Registry | Polls | What's New | Raffle | Photo of the Month | Sponsors]

95 Bulletin Board
1999-2009 [Subscribe to Daily Digest]
(Search Author's Posts: e.g. Keyword:username)*Members Only


[Main 95 Bulletin Board | BBFAQ | Prev by Date | Next by Date | Post Followup ] Member Login / Signup [Latest Member Gallery Photos]
Re: Radio - No Sound
Like This Post:
Posted by Scott C (more from Scott C) on Thu, 16 Mar 2017 11:22:34 Share Post by Email
In Reply to: Radio - No Sound, Scott C, Fri, 10 Mar 2017 16:27:11
Alert me when someone posts in this thread:

Just to update and close out this thread:

The sounds are back! Everyone gave good suggestions but the problem turned out not to be obvious.

-The head had power and seemed to work, at least as viewed on the SID
-No sound through any input source
-The main amp had power and a replacement amp did not fix it
-The wagon has two antenna amp units - was heading in this direction as the next step but put this on hold for other car service

I had the car in at my former dealer (now independent repair shop) to get the serpentine belt replaced, the short belt kit installed and a few noisy pulleys replaced. I also mentioned the radio problem.

His suggestion was to re-marry the head to the car. That didn't work, so he divorced my head, divorced the head from one of his parts cars and then married it to my car - and it worked!

So the problem turned out to be the head itself even though it still seemed to function (minus the sound). My head is probably done as he doesn't see sending it out as cost effective.

His dealership ran for decades and he told me he'd only ever replaced one amp in one of these cars and that was only because the thing wouldn't power off.

After all this I still don't really know the best way to diagnose a fault in this sound system as it seems there are multiple ways to cause the same condition. I'm in for an eBay amp that I don't need and the time and effort to get to this point, which isn't too bad once all is said and done.

Thanks again for all the suggestions! Hope this might help someone else someday.

posted by 132.3.6...

Posts in this Thread:
Alert me when someone posts in this thread:

Post a Followup

No Site Registration is Required to Post - Site Membership is optional (Member Features List), but helps to keep the site online
for all Saabers. If the site helps you, please consider helping the site by becoming a member.

Name: Member Login / Signup [Latest Member Gallery Photos]
E-Mail: (Optional)
Re-Enter E-Mail: (Confidential & Secure - Not revealed to other users!)
Note: Please check your spam folder for BB responses.

Subject:

Posting rules are simple - No for sale/wanted ads may be posted here - use the site classifieds.
You may not cross-post your message to multiple BBs.
Not permitted: political/religious topics and being disrespectful (personal attacks, insults, etc...).
Site Members do not see any red text, inline ad links, bottom of page anchor ads, box ads, or anti-spam check.

Message: (please no for sale/wanted classifieds - post those in the Saabnet.com Classifieds)
Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).


Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post above, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).

Optional Link: (e.g. http://www.saabnet.com/)
Link Title: (Optional)
Optional Photo/Image Link: (e.g. http://www.saabnet.com/img.jpg)
Photo/Image to Upload: (Please be patient while file uploads)





The content on this site may not be republished without permission. Copyright © 1988-2021 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]

This is a moderated bulletin board - Posting is a privilege, not a right. Unsolicited commercial postings are not allowed (no spam). Please, no For Sale or Wanted postings, SERIOUSLY. Classifieds are to be listed in The Saab Network Classifieds pages. This is a problem solving forum for over 250,000 Saab owners, so expect to see problems discussed here even though our cars are generally very reliable. This is not an anything goes type of forum. Saabnet.com has been a moderated forum since 1988. For usage guidelines, see the Saabnet.com Mission and Purpose Page. Please remember that you are not anonymous. Site Contact | Site Donations | Other Sites by SP - Poverty2Prosperity.org
Your address is: 3.239.7.207 - Using CCBot/2.0 (https://commoncrawl.org/faq/) - Logged.


Site Members do not see red text instructions, bottom of the page anchor ads, or box ads.
Click here to see all the Site Membership Benefits!