Lost time on NAV screen after battery disconnected for repair - Saab 9-5 Bulletin Board - Saabnet.com


[General | Members | C900 | 9000 | NG900 & OG93 | 93 | 95 | NG95 | 99 | Sonett | Vintage Models | Performance | Detail | Clubs & SOC | Other Cars | FAQs | Gifts | Member Photo Galleries | Member Directory | Classifieds | Service/Mechs | Manuals | *Buddy Registry | *Mileage Registry | Polls | What's New | Raffle | Photo of the Month | Sponsors]

95 Bulletin Board
1999-2009 [Subscribe to Daily Digest]
(Search Author's Posts: e.g. Keyword:username)*Members Only


[Main 95 Bulletin Board | Post Followup | BBFAQ ] [ Prev by Date ] [ Next by Date ] Member Login / Signup [Latest Member Gallery Photos]
Lost time on NAV screen after battery disconnected for repair
Like This Post:
Posted by CraigU [Email] (#1999) [Profile/Gallery] (more from CraigU) on Fri, 31 May 2019 12:20:35 Share Post by Email
Alert me when someone posts in this thread:

Just and FYI here for any of you with 2005 and up Nav system in their SAAB. After recently having the high pressure line in the clutch replaced and the battery disconnected, where the clock would normally displayed in a button in the upper right corner of the display, it is now blank. If you press and hold this button, the clock set-up screen is pulled up. The problem is none of the adjustments are active or changeable and the clock display button is always blank.

After some research this is what I have found. We are most definitely not alone in this. The Corvette and Cadillac forums are full of people having exactly the same issue. GM in the States have opened a service bulletin on it and seemingly Nippon Denso are aware of the issue but only time will tell if a fix comes.

Unless a new Firmware for SAAB becomes available (which I doubt since lately from what I've read, all updates/fixes etc for MY '05-'10 from GM cover everything except SAAB). Hopefully Denso should provide a downloadable update direct from their site for the units at no cost since essentially this seems to have been an oversight on Denso's part, a defect essentially.

Time will tell (no pun intended, or is it?...)
I have approached Denso direct with this, I suggest as many of you, that have this problem (or will have the problem in the future, you will if you disconnect your battery, so get proactive I would say) do the same. Maybe that helps and all we have to loose in the end is time. (Was that a pun too? Not sure.)

_______________________________________ Craig


Posts in this Thread:
Alert me when someone posts in this thread:

Post a Followup

No Site Registration is Required to Post - Site Membership is optional (Member Features List), but helps to keep the site online
for all Saabers. If the site helps you, please consider helping the site by becoming a member.

Name: Member Login / Signup [Latest Member Gallery Photos]
E-Mail: (Optional)
Re-Enter E-Mail: (Confidential & Secure - Not revealed to other users!)
Note: Please check your spam folder for BB responses.

Subject:

Posting rules are simple - No for sale/wanted ads may be posted here - use the site classifieds.
You may not cross-post your message to multiple BBs.
Not permitted: political/religious topics and being disrespectful (personal attacks, insults, etc...).
Site Members do not see any red text, inline ad links, bottom of page anchor ads, box ads, or anti-spam check.

Message: (please no for sale/wanted classifieds - post those in the Saabnet.com Classifieds)
Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).


Links are now automatically made active, no need for any special code (or use the Option Link field below) - don't put links in () or end with a '.'
To add inline images to your post above, use [img]http://www.domain.com/img.jpg[endimg] (or use the Optional Image Link field below).

Optional Link: (e.g. http://www.saabnet.com/)
Link Title: (Optional)
Optional Photo/Image Link: (e.g. http://www.saabnet.com/img.jpg)
Photo/Image to Upload: [Member Only Feature] - Sign Up





The content on this site may not be republished without permission. Copyright © 1988-2020 - The Saab Network - saabnet.com.
For usage guidelines, see the Saabnet.com Mission and Purpose Page.
[Contact | Site Map | Saabnet.com on Facebook | Saabnet.com on Twitter | Shop Amazon via TSN | Site Donations]

This is a moderated bulletin board - Posting is a privilege, not a right. Unsolicited commercial postings are not allowed (no spam). Please, no For Sale or Wanted postings, SERIOUSLY. Classifieds are to be listed in The Saab Network Classifieds pages. This is a problem solving forum for over 250,000 Saab owners, so expect to see problems discussed here even though our cars are generally very reliable. This is not an anything goes type of forum. Saabnet.com has been a moderated forum since 1988. For usage guidelines, see the Saabnet.com Mission and Purpose Page. Please remember that you are not anonymous. Site Contact | Site Donations | Other Sites by SP - Poverty2Prosperity.org
Your address is: 3.226.248.180 - Using CCBot/2.0 (https://commoncrawl.org/faq/) - Logged.


Site Members do not see red text instructions, bottom of the page anchor ads, or box ads.
Click here to see all the Site Membership Benefits!